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TEGAM is a manufacturer of electronic test and measurement equipment for metrology, calibration, and 

production test. We also provide repair, calibration, and other support services for a wide variety of test 

and measurement equipment including RF power sensor calibration systems, RF attenuation measurement 

systems, ratio transformers, arbitrary waveform generators, micro-ohmmeters, LCR meters, handheld 

temperature calibrators, thermometers, humidity and temperature control devices, and more. 

 

TEGAM also repairs and calibrates test and measurement equipment formerly manufactured by Electro-

Scientific Industries (ESI), Gertsch, Keithley Instruments, Lucas Weinschel, and Pragmatic Instruments. A 

complete list can be viewed on our Product Service Directory at www.tegam.com 

 

For more information about TEGAM and our products, please visit our website at www.tegam.com: or 

contact one of our customer service representatives at sales@tegam.com or 800-666-1010. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
 
10 Tegam Way, 

 Geneva, Ohio 44041 

  

 Telephone: (440) 466-6100 

 Fax: (440) 466-6110 

 E-mail: sales@tegam.com  
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Safety Information & Precautions: 

The following safety information applies to both operation and service personnel. Safety precautions and 

warnings may be found throughout this instruction manual and the equipment. These warnings may be in 

the form of a symbol or a written statement. Below is a summary of these precautions. 

 

Terms in This Manual: 

CAUTION statements identify conditions or practices that could result in damage to the equipment or 

other property. 

 

WARNING statements identify conditions or practices that could result in personal injury or loss of life. 

 

Terms as Marked on Equipment: 

CAUTION indicates a personal injury hazard not immediately accessible as one reads the marking, or a 

hazard to property including the equipment itself. 

 

DANGER indicates a personal injury hazard immediately accessible as one reads the marking. 

 

Symbols:  

As Marked in This Manual: 

 

!
 

 

This symbol denotes where precautionary information may be found. 

 

As Marked on Equipment: 

 

!
 

 

CAUTION – Risk of Danger 

 

 

DANGER – Risk of Electric Shock 

 

 

Earth Ground Terminal 

   l 

 

On 

O 

 

Off 

 

 

 

Frame or Chassis Terminal 

 Earth Ground Terminal 

 
 

 

Alternating Current 
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Section I – License Agreement 

License 
This License Agreement (Agreement) is a legal agreement between you the Customer (either an individual 

or a single entity) and TEGAM, Inc. for the software product contained in this package and online or 

electronic documentation and may include associated media and printed materials (SOFTWARE PRODUCT 

or SOFTWARE). TEGAM, Inc. is willing to license the Software to you pursuant to the terms of this 

Agreement only if you purchased the Software from an Approved Source (as defined herein), and you 

accept all of the terms contained in this Agreement.  By downloading, installing, copying, or otherwise 

using the SOFTWARE PRODUCT, you agree to be bound by the terms of this Agreement. If you do not 

agree to the terms of this Agreement, do not install or use the SOFTWARE PRODUCT. Downloading, 

installing, copying or using the Software Product constitutes acceptance of this Agreement.  For purposes 

of this Agreement, an “Approved Source” means either (A) TEGAM, Inc., or (B) a distributor or reseller 

authorized by TEGAM, Inc. to distribute or sell the Software Product to end users within your territory. 

1. GRANT OF LICENSE.  

This Agreement grants you certain limited, non-exclusive rights. TEGAM, Inc. reserves all rights not 

expressly granted to you.  The Software is licensed for unlimited use at the Customer’s location as 

identified by the Customer as the ship-to location of the Software. This license is limited to two client 

workstations that can run the Software at a single Customer location.   

2. COPYRIGHT.  

All rights, title, and copyrights in and to the SOFTWARE PRODUCT (including, but not limited to, any 

images, photographs, animations, video, audio, music, text, and "applets" incorporated into the 

SOFTWARE PRODUCT) and any copies of the SOFTWARE PRODUCT are owned by TEGAM, Inc. or its 

suppliers. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions. 

Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material, except that you 

may make one copy of the SOFTWARE PRODUCT solely for backup or archival purposes. You may not copy 

the printed materials accompanying the SOFTWARE PRODUCT.  

3. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS. 

a. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not 

reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent 

that such activity is expressly permitted by applicable law notwithstanding this limitation.  

b. Rental. You may not rent, lease or sublicense the SOFTWARE PRODUCT.  

c. Software Transfer.  The Software is licensed to a single company; you may not transfer, sell or 

redistribute the Software to any parties outside your company or organization.   

d. Modifications.  If the source code was provided with the SOFTWARE PRODUCT you or your 

organization may make modifications to the code.  After user modifications are made to the Software 

you must send TEGAM, Inc. a copy of the modified source code.  

e. Termination. Without prejudice to any other rights, TEGAM, Inc. may terminate this Agreement 

if you fail to comply with the terms and conditions of this Agreement. In such event, you must destroy 

all copies of the SOFTWARE PRODUCT and all of its component parts.  

4. EXPORT RESTRICTIONS.  

You agree that neither you nor your customers intend to or will, directly or indirectly, export or transmit 

(a) the SOFTWARE PRODUCT or related documentation and technical data, or (b) your  process or service 

that is the direct product of the SOFTWARE PRODUCT, to any country to which such export or 

transmission is restricted by any applicable U.S. regulation or statute, without the prior written consent, if 

required, of the Bureau of Export Administration of the U.S. Department of Commerce, or such other 

governmental entity as may have jurisdiction over such export or transmission.  

5. U.S. GOVERNMENT RESTRICTED RIGHTS. 

The SOFTWARE PRODUCT and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or 

disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights 

in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) 
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of the Commercial Computer Software - Restricted Rights at 48 CFR 52.227-19, as applicable. 

Manufacturer is TEGAM, Inc., an Ohio corporation.  

6. MISCELLANEOUS. 

If you acquired this product in the United States, this Agreement is governed by the laws of the State of 

Ohio. Should you have any questions concerning this Agreement, or if you desire to contact TEGAM, Inc. 

for any reason, please contact our website at https://www.tegam.com or sales@tegam.com.  

7. NO WARRANTIES. To the maximum extent permitted by applicable law, TEGAM, Inc. expressly 

disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related 

documentation are provided "as is" without warranty of any kind, either express or implied, including, 

without limitation, the implied warranties of merchantability, fitness for a particular purpose, or non-

infringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with 

you.  

8. LIMITATION OF LIABILITY. TEGAM, Inc.'s entire liability and your exclusive remedy under this 

Agreement shall not exceed five dollars (US $5.00).  

9. NO LIABILITY FOR CONSEQUENTIAL DAMAGES. To the maximum extent permitted by applicable 

law, in no event shall TEGAM, Inc. or its distributors, resellers or suppliers be liable for any consequential 

or incidental damages whatsoever (including, without limitation, damages for loss of business profit, 

business interruption, loss of business information, or any other pecuniary loss) arising out of the use of, 

or inability to use, this TEGAM, Inc. product, even if TEGAM, Inc. has been advised of the possibility of 

such damages. Because some states/jurisdictions do not allow the exclusion or limitation of liability for 

consequential or incidental damages, the above limitation may not apply to you.

https://www.tegam.com/
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Section II – Installation 
 

Installation Overview 
In order to run the PS-Cal software all of the supporting software and hardware must first be installed on 

the workstation.  Along with the PS-Cal software, all of the required software is shipped on the PS-Cal CD.   

 

On the CD you will find the following files and directories: PS-Cal.exe, SetupPS-Cal.msi, setup.exe, PS-

CAL-900.pdf (most current revision), licenseAgreement.pdf, changelog.pdf, and R&S Files-.   

 

 

Installing .Net Framework 
PS-Cal requires Microsoft .Net® 4.0 Framework or higher. If necessary, update the workstation .Net 

installation at microsoft.com.  

 

 

Installing Proper VISA Libraries  
PS-CAL is designed to work with any VISA library. Use the manufacturer VISA installations for your 

hardware requirements.  

 

Example: If using National Instruments GPIB-USB-HS you would need the National Instruments VISA 

libraries. 

 

 

Installing PS-CAL 
Once .Net Framework and VISA libraries are installed, use the Setup.exe found on the PS-CAL installation 

disk to install the PS-Cal software. 
 
First Run 
Power sensor calibration templates must be installed before using PS-Cal. When running PS-Cal for the 

first time, select Tools -> Generate Blank Templates. PS-Cal will generate blank templates for all 

supported sensors and display a notification once it completes its process. 
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Section III – Work Station Configuration  
 

Measurement Methodology Selection  
PS-Cal allows for multiple power sensor calibration methodologies. When using with TEGAM hardware the 

RFBridge_MultiRun methodologies should be used.   

 

Station Configuration 
PS-Cal maintains a station configuration file on the local hard drive storing a list of the standards used and 

the VISA resource string / GPIB address of the standard.   

To open the station configuration file, select Configuration -> Edit Configuration  

 

 
Figure 3.1 Station Configuration 

 
The Available Drivers list on the left hand side contains a list of all the standards this version of PS-Cal 

supports.  The Configured Drivers list on the right lists all the standards configured on this station.  This 

list contains the name of the driver followed by the instance of the driver.  The instance of the driver is 

used to distinguish instruments in configuration using two or more standards of the same type.  For 

example, if the station is configured with two TEGAM 1830A’s, the Configured Drivers list would contain 

two configuration lines, “TEGAM 1830A” and “TEGAM 1830A”. 

Note: Only the standards listed in the Configured Drivers list are available for use in PS-Cal.  All 

drivers must be configured before they are available in the template configuration wizards.  

The Driver Details section of the form shows the configuration details for this instrument.  Each driver 

must be configured with an Instance and Resource String.   

The Instance must contain a number that uniquely identifies the driver / instrument.  Typically, the first 

instrument used is 1 and any other instruments of the same type are 2, 3, 4, etc.    
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The Resource String is a standard VISA resource string.  The Resource String defines how PS-Cal will 

communicate with the instrument.  Typically, instrument communication is done over the GPIB bus, but 

PS-Cal is able to communicate with instruments via Ethernet, USB and RS-232.  The VISA resource string 

is a strictly formatted string.  GPIB configured instruments are formatted as follows: 

 

     GPIB<Card Number>::<GPIB Address>::INSTR. 

 

Note: Refer to the National Instruments VISA documentation for configuration formats for Ethernet, RS-

232 and USB instruments. 

 

The second tab on the Station Configuration form also contains a list of global station variables.  PS-Cal 

uses the variables as global variables to set values, custom configurations and execution options.  

 

 
Figure 3.2 Station Variables 

 

 

After the Station Configuration has been edited, the data can be saved back to the configuration  files 

by pressing the Save and Close button.   

 

 

Editing Calibration Data for Standards 
The exact data required for each standard varies depending on the Measurement Methodology being used 

and configuration of the test station.  PS-Cal has a set of forms to help users manage the calibration data 

associated with the station’s standards.   

 
 

Editing Power Sensor Data 
To edit calibration data files for a power sensor standard select Configuration -> Edit Standard Data -

> Power Sensor in the menu. PS-Cal opens a file dialog box.  
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Section III – Work Station Configuration  
 

By default, the Power Sensor Calibration Data files are stored in the “C:\PS-Cal_V4\Standards\” directory.  

If you are creating Data files for the first time, you can load a blank data file from the “C:\PS-

Cal_V4\_Blank Templates\” directory.   

 

Navigate to the directory where the data file is stored for the sensor file you wish to edit or view, select 

the file, and then press Open.  

 

 
Figure 3.3 Editing Power Sensor Data 

 

 

PS-Cal loads the data into a Power Sensor Data Edit form.  This form allows the user to update the rho 

and cal factor data, each with their own tab on the edit form.  The exact data that must be entered varies, 

depending on the measurement methodology used to test the UUT power sensors.  Refer to the 

Measurement Methodology to determine exactly what data is required.  When in doubt, enter data in all 

the data fields.  

 

 
Figure 3.4 Editing Power Sensor Data GUI 

 
When finished editing the data, press the Save button to save the data back to disk.  Once the data is 

saved, press the Close button to exit the form. 
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Editing Power Splitter Data 
To edit calibration data files for a power Splitter standard, select Configuration -> Edit Standard Data -

> Power Splitter in the menu. PS-Cal opens a file dialog box. By default, the Power Splitter Calibration 

Data files are stored in the “C:\PS-Cal_V4\Standards\” directory.  If you are creating Data files for the first 

time, you can load a blank data file from the “C:\PS-Cal_V4\_Blank Templates\” directory (see Creating 

Templates for more information).  Navigate to the directory where the data file is stored for the splitter file 

you wish to edit or view, then press Open.  

 
Figure 3.5 Editing Power Splitter Data 

 
PS-Cal will load the data into a Power Splitter Data Edit form.  This form allows the user to update the 

header, S11, S22, S33, S21 and S31 data, each with their own tab on the form.  The exact data that must 

be entered varies depending on the measurement methodology used to test the UUT power sensors.  

Refer to the Measurement Methodology section to determine exactly what data is required.  When in 

doubt enter all the data fields.  

 
Figure 3.6 Editing Power Splitter GUI 

 
When finished editing the data, press the Save button to save the data back to disk.  Once the data is 

saved, press the Close button to exit the form. 
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Section III – Work Station Configuration  
 

 

Editing Thermistor Mount Data 
To edit calibration data files for a power splitter standard, select Configuration -> Edit Standard Data -

> Bolometer \ Mount in the menu. 

 

 
Figure 3.7 Editing Thermistor Mount Data 

 
PS-Cal opens an edit form with three tabs on the top, Load Data, Import Data and New Data.  The 

Load Data tab allows the user to load existing PS-Cal formatted data files from the hard drive for editing.  

The Import Data tab allows the user to import data from various formats and converts the format to a 

PS-Cal compatible format.  The New Data tab allows the user to create a blank data file. 

 
To load a TEGAM-formatted data file, select Import Data. In the Data Format field, select TEGAM.dat.  

Click the Import Dat button, navigate to the Standards directory in the resulting dialog box. Select the 

appropriate TEGAM data file and click Open.  

 

PS-Cal will import the information from the selected data file. To verify the data, click the Data tab to see 

the imported values. 

 

Click Save to save the data as a PS-Cal-compatible file. 
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Section IV - Operating Instructions 
 

Creating a Calibration Template 
PS-Cal is a template-driven calibration package.   This allows you to create several calibration 

configurations and save each configuration as a separate template.  To recall a configuration in the future,  

load the appropriate template. 

   

Blank templates are created in PS-Cal by clicking Tools -> Create Blank Templates.  These blank 

templates are stored in the   “C:\PS-Cal_V4\_Blank Templates\” directory. 

 

 
Figure 4.1 Creating a Calibration Template 

 
The first step in creating a calibration template is to open a blank template.  In the PS-CAL menu, select 

File -> Load and navigate to the “C:\PS-Cal_V4\_Blank Templates\” directory.  Select the blank 

template of the power sensor model you are creating a calibration template for and press Open. 

PS-Cal reads the required tests from the blank temple and prompts you for details on the Measurement 

Methodology and standards you will use for this calibration.  The required test steps for each power sensor 

vary based on the manufacturer’s written requirements.  PS-Cal prompts you through the calibration steps 

including rho, cal factors, linearity, and EEPROM read / write. 
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Section IV - Operating Instructions 
 

 
Figure 4.2 Select a Measurement Method 

 
In the Select Measurement Method form, PS-Cal displays a list of available Measurement Methodologies 

in the top section.  As you select each Measurement Methodology, PS-Cal updates the lower section of the 

form with the details of the Measurement Methodology.  Once you have decided on the Measurement 

Methodology, select it and press Continue.  

NOTE: For Cal Factor tests using the TEGAM 1806(x) Type IV Power Meters or the 1830A RF Thermistor 

Power Meter, select from the RFBridge_Multirun methodologies.  

 
 

 
Since each Measurement Methodology has differing standard requirements, PS-Cal prompts you for each 

standard required by the Measurement Methodology.  In the Select Compatible Driver form, PS-Cal 

displays a list of configured instruments/drivers compatible with Measurement Methodology.  If you do not 

see your standard/driver in the list, it may not be configured.  You can edit the station configuration by 

 
Figure 4.3 Select a Compatible 

Driver 
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pressing the Station Configuration button (see section on Station configuration).  Once you have 

decided on the driver you want to use, select it and press Continue. 

After all the Standards have been selected in PS-Cal, you are prompted to set the test parameters for the 

test group.  These parameters configure the specific options of the test methodology allowing you to fine 

tune the specifics of each test methodology.  For specifics on each option, see the supporting test 

methodology documentation.   

 

Note: Test parameters are editable after the template has been configured.  Most test methodologies have 

a PARAM button which loads the parameters window. 

   

PS-Cal repeats this process of selecting the Measurement Methodology and Drivers until all Measurement 

Methodologies and drivers have been configured.   

 

Loading a Calibration Template 
 

 

 
Figure 4.4 Load a Calibration Template 

 
To load a calibration template in the PS-CAL menu, select Calibration Template -> Load and navigate 

to the “C:\PS-Cal_V4\Calibration Templates\” directory.  Select the calibration template of the power 

sensor you are calibrating and then press Open. 

 

Setting Additional Parameters in the Calibration Template 
After creating a calibration template, there are some additional parameters and data that may need to be 

updated.  The parameters set variables defining how PS-Cal performs the calibration, and they vary with 

each test methodology.   Though these variables can be set and updated at any time, for consistency, we 

recommend that you update them when the template is first created, and if they are modified later, that 

you save the updates back to the template file.   

For each test in the power sensor template there is a parameters button on the screen.  The parameters 

window is opened by pressing the “Param.” button.  Simply update the value in the value column and 

press Close. 
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Figure 4.5 Configuring Parameters 

 
In addition to the parameters data, the following values may need to be updated before the calibration 

template is saved: 

 

1) Uncertainties By default, PS-Cal calculates on the measurement uncertainties and updates the 

column if the column contains “- -. “  If you would like PS-Cal to report uncertainties that are on 

your scope, you can update this column and save the changes back to the template.  This will force 

PS-Cal to use your uncertainties on all reports. 

2) OnLabel For many power sensors that have a calibration label, the calibration template can test 

more frequencies than fit on the label.  Under the Cal Factor test there is an OnLabel column.  

This column controls what frequencies will be printed on the calibration label and the data can be 

updated with Yes and No values.  PS-Cal ignores this data for power sensors that do not require a 

printed Cal Factor label. 

Once all the data and parameters are set in the power sensor template, save the template to update it 

with the changes.  See “Saving a Calibration Template. “ 
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Running a Calibration  
Once a power sensor template is loaded, PS-Cal displays one tab for each required test step.  The exact 

steps required for each power sensor and each measurement methodology vary.  These tabs are loaded in 

order of operation from left to right. 

 

 
Figure 4.6 Running a Calibration 

 
Two default tabs are loaded with every power sensor.  The first is the UUT tab containing information 

about the Unit Under Test (UUT, also known as Device Under Test, DUT) and the work order.  Data such 

as the UUT Serial number, Asset number, Job number, and the Calibration Technician (Cal Tech) who 

performed the calibration must be updated on this tab.  

 

 
Figure 4.7 Calibration Default Tabs 

 
The last tab is the Cal Report tab, which is used to print the report data for the calibration.  Once all the 

steps between the UUT tab and the Cal Report tab have been completed, the data is ready to print. 
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Under each test procedure tab, there is a button bar with a button for each of the steps required to 

complete that calibration step.  Like the tabs, the buttons are organized in step order from left to right.  

The exact buttons that appear on the form varies with each test methodology.  

 

 
Figure 4.8 Calibration GUI 

These buttons are enabled and disabled as required by the test procedure. A button remains disabled until 

necessary prerequisite steps are performed. For example, the Cal button is turned off until the Configure 

Station button has been pressed and the configure station operation has been completed.  Then PS-Cal 

turns on the Cal button and allows you to go to the next step in the calibration process.  

Another button to make a special note of is the Halt button.  This button is used to halt the application. 

For example, if for some reason something was not hooked up correctly or you just need to stop the 

program, simply press the Halt button and PS-Cal will stop executing the calibration steps and reset all 

the standards to a safe state.  

 

Saving Calibration Data 
After you have completed a calibration (or at any point during the calibration), you can save the 

calibration data to disk.  We recommend you save your calibration data often, to prevent loss of data due 

to a power outage or power failure.  

To save your calibration data 

1. Select UUT -> Save As and navigate to the “C:\PS-Cal_V4\CalResults\” directory. 

2. Enter the file name of the calibration data you are saving (we recommend you use a standard 

naming conventions of either <JobNumber>.xml or <AssetNumber><CalDate>.xml).  

3. Press Save.  

Uploading Calibration Data 
If the sensor has an EEPROM (Electronic, Erasable Programmable Read Only memory), you can upload the 

calibration data to the sensor.   

To upload the calibration data: 

1. Click the Upload Data tab.   

2. Click the Download Data button. This brings up the data for viewing. You will also see the word 

“Ready!” indicating that the data is now available for upload to the EEPROM on the sensor. 

3. Click the Save/Backup Sensor Data to File button. This makes sure that the data is saved, in 

case there is a malfunction with the sensor prior to uploading. 

4. Select whether to upload the data for 

a. Header 

b. Cal Factors 

c. Linearity   

5. Click the Upload Cal Data button. A dialog box prompts you to cycle the power on the power sensor. 

 

Note: to test that the data uploaded correctly, after cycling power on the sensor, with the sensor still 

connected, click the Download Data button. 
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Printing a Calibration Label 
If the sensor is a non-EEPROM based sensor (it does not have an Electronic, Erasable Programmable Read 

Only memory), it may require a calibration label to be printed.  In order to print the calibration label you 

must have a compatible label printer.  Once all the calibration steps have been completed the power 

sensor calibration label is ready to be printed.   

To print the calibration label: 

6. Select the Print Label tab of the power sensor being calibrated.  Under this is a report viewer tool 

used to generate the label.  PS-Cal supports several different label sizes.   

7. Select the report size from the drop down.   

8. Press the Run Report button.  PS-Cal presents a print view of the report in the Report Viewer 

window.   

9. To print the report, press the Print button. 

Note: If the report is generating a two page label, remove test points from the label by editing the 

OnLabel under the Cal Factors tab.  Columns that contain “Yes” in the OnLabel field will be 

printed on the label. 
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Printing the Calibration Report 
Once all the steps of a calibration are completed, the results of the calibration are ready to be printed.  

The last tab on the form is the Cal Report tab, which combines all the data from each tab into one single 

report.  

 

 
Figure 4.9 Print Calibration Report 

 
To print the Calibration Report: 

1. Select the Cal Report tab 

2. Press the Run Report button.  PS-Cal presents a print view of the report in the Report Viewer 

window.   

3. To print the report, press the Print button.  

 
Figure 4.10 Calibration Report Preview 

 



 
 

 

10 TEGAM WAY • GENEVA, OHIO 44041 440-466-6100 • FAX 440-466-6110 • www.tegam.com 

4-9 

Section IV - Operating Instructions 
 

PS-CAL in Batch Mode 
PS-Cal is able to calibrate power sensors in batch mode.  Though PS-Cal can only calibrate a single sensor 

at a time, Batch Mode allows the operator to configure that station to test one power sensor, and then use 

that configuration to calibration the next sensor in the batch.  This process saves time, because many 

power sensor calibration configuration steps are time consuming.  
  

 
Figure 4.11 Batch Mode 

 

To use PS-Cal in Batch Mode: 

1. Click on UUT in the menu bar 

2. Select New.  

This adds an Asset tab.  

3. Label the tab by selecting it, and then selecting the UUT tab, and entering the asset number in the 

Asset Number field. 

4. The new asset tab is now labeled. 

You can now select the newly added asset by clicking its tab along the left. Configuration information and 

data collected on one power sensor is shared with all the power sensors that are open.  

 


